Arduino Due + Due3Dom - problemy z ekstruderem

szadok71
Posty: 26
Rejestracja: 22 sie 2017, 13:34
Kontaktowanie:

Arduino Due + Due3Dom - problemy z ekstruderem

Postautor: szadok71 » 12 lut 2018, 17:54

Witam,

Po rozwiązaniu problemów z wyświetlaczem, na drodze do pełni szczęścia stanął ekstruder.
Problem podobny do tego zgłaszanego przez kolegę adziaki - niestety nie widzę rozwiązania:
http://www.fabrykator.pl/board/viewtopic.php?f=12&t=242&start=340#p17367

Mimo dogrzania do temperatury 190 a nawet 230 stopni, silnik ekstrudera ani drgnie.
Silnik sprawdzałem na innym wyjściu i działa. Przezornie wymieniłem też stepstick'a ale generalnie jest chłodny podczas prób wysterowania.
Przy ręcznym sterowaniu przez LCD, po dogrzaniu głowicy, poruszanie enkoderem powoduje zmianę wiświetlanej wartości milimetrów wysuwanego filamentu ale nie ma żadnego ruchu na głowicy.
Widziałem, że kolega adziaki wymieniał płytkę Due3Dom ale to nic nie pomogło więc problem jest chyba gdzie indziej...

Dla przypomnienia, pracuję na firmware Repetier 1.0.1.
Zrobiłem próbę druku bez filamentu. Wszystko ruszyło ale silnik ekstrudera nie działał...

Garreth
Posty: 981
Rejestracja: 20 kwie 2016, 6:59
Lokalizacja: Katowice
Kontaktowanie:

Re: Arduino Due + Due3Dom - problemy z ekstruderem

Postautor: Garreth » 12 lut 2018, 18:45

Due3dom czy due3dom mini?

szadok71
Posty: 26
Rejestracja: 22 sie 2017, 13:34
Kontaktowanie:

Re: Arduino Due + Due3Dom - problemy z ekstruderem

Postautor: szadok71 » 12 lut 2018, 18:49

Due3Dom mini rev2.0

Wybieram w konfiguracji Ekstruder0. Wygląda tak jakby brakowało jakiegoś sygnału startującego. Albo ten sygnał zwrotnie nie trafiał tam gdzie trzeba do Arduino...

Garreth
Posty: 981
Rejestracja: 20 kwie 2016, 6:59
Lokalizacja: Katowice
Kontaktowanie:

Re: Arduino Due + Due3Dom - problemy z ekstruderem

Postautor: Garreth » 12 lut 2018, 18:58

2018-02-12 19_56_45-due3dom-mini-pinout.jpg (1468×1656).png


Przedzwoniłbym miernikiem ścieżki tych 3 sygnałów: E-Dir, E-STP, E-Ena
Nie masz wymaganych uprawnień, aby zobaczyć pliki załączone do tego posta.

szadok71
Posty: 26
Rejestracja: 22 sie 2017, 13:34
Kontaktowanie:

Re: Arduino Due + Due3Dom - problemy z ekstruderem

Postautor: szadok71 » 12 lut 2018, 19:16

Przedzwonione. A6, A7, A8 z płytki Arduino dochodzi do płytki stepstick'a ekstrudera na piny DIR, STP i ENA.

W edytorze firmware Repetier znalazłem w zakładce Tools, takie ustawienie:
Invert enable signal (EXT0_ENABLE_ON)
, ale zmiana tego ustawienia nic nie zmieniła.

Awatar użytkownika
Miś
Posty: 750
Rejestracja: 22 kwie 2016, 14:23
Kontaktowanie:

Re: Arduino Due + Due3Dom - problemy z ekstruderem

Postautor: Miś » 12 lut 2018, 19:19

A ja bym napisał PW do kol. Adziaki, bo jego delta na due3dom już od dawna drukuje, więc musiał opanować ten problem, tylko zapomniał się pochwalić w jaki sposób.
-- MIŚ --

szadok71
Posty: 26
Rejestracja: 22 sie 2017, 13:34
Kontaktowanie:

Re: Arduino Due + Due3Dom - problemy z ekstruderem

Postautor: szadok71 » 12 lut 2018, 19:44

Napisałem... ;) i czekam z nadzieją na odpowiedź.

Garreth
Posty: 981
Rejestracja: 20 kwie 2016, 6:59
Lokalizacja: Katowice
Kontaktowanie:

Re: Arduino Due + Due3Dom - problemy z ekstruderem

Postautor: Garreth » 12 lut 2018, 19:54

A zanim Adziaki nie odpowie moglbys w sumie sprawdzic marlina, skoro IDE dziala :)

Awatar użytkownika
adziaki
Posty: 480
Rejestracja: 21 kwie 2016, 15:03
Lokalizacja: Koszalin
Kontaktowanie:

Re: Arduino Due + Due3Dom - problemy z ekstruderem

Postautor: adziaki » 12 lut 2018, 20:08

U mnie winowajcą były zimne luty na płytce Due3dom od silnika extrudera. Po przegrzaniu złacz wszystko działa do tej pory :OK:
Sam @Krzysztof naprawiał :)

szadok71
Posty: 26
Rejestracja: 22 sie 2017, 13:34
Kontaktowanie:

Re: Arduino Due + Due3Dom - problemy z ekstruderem

Postautor: szadok71 » 12 lut 2018, 20:55

Dzięki. Jutro się temu przyjrzę i ewentualnie skontaktuję się z Krzysztofem czy własnoręczne przegrzanie lutów nie spowoduje utraty gwarancji. :-)


Wróć do „Problemy i porady”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 5 gości