Lerdge + tmc2100 Gubi kroki słabo trzyma

Pytania techniczne dotyczące budowy, działania, itp.
77PAGO77
Posty: 4
Rejestracja: 15 sty 2018, 8:10
Kontaktowanie:

Lerdge + tmc2100 Gubi kroki słabo trzyma

Postautor: 77PAGO77 » 18 sty 2018, 18:55

Witam zakupiłem elektronikę Lerdge + stepy tmc2100 i jestem delikatnie mówiąc załamany , Ustawiłem max prądy na STEPSTICKACH puszczam druk i po 4-6 mm zaczyna gubić kroki niekiedy po 10 mm w Z , w czasie druku wystarczy delikatnie złapać za karętkę / stolik i już gubi kroki , bez ustawienia prądu / napięcia było jeszcze gorzej , to nie wina mechaniki / zasilacza / silników bo wcześniej chodziła tam elektronika od Anet A8 no i było no powiedzmy ok jak na Anet chciałem coś lepszego to wsadziłem sunbeam 2.0 i jak łapałem za stolik to drukarka jechała do mnie zero gubienia kroków na przyspieszeniu 2400 i prędkości 180mm/s ale chciałem coś jeszcze "fajniejszego " i zakupiłem Lerdge + tmc2100 i ZONK i nie mogę drukować nawet na 60mm/s oraz przyspieszeniach 900 bo kroki gubi .
Stepy zmienione na tryb spreadcycle i mało to dało wsadziłem jeszcze A4988 trochę lepiej "trzymają ale nie tak jak zintegrowane sunbeam 2.0 "

Co można jeszcze zrobić by było cicho "przyzwoicie" i nie gubiło kroków oraz dało się drukować z normalnymi prędkościami bo nie po to wydałemkasę by drukować 20mm/s i przyspieszenia 300 :evil:

Cała elektronika chłodzona wentylatorami nic się nie grzeje

Garreth
Posty: 978
Rejestracja: 20 kwie 2016, 6:59
Lokalizacja: Katowice
Kontaktowanie:

Re: Lerdge + tmc2100 Gubi kroki słabo trzyma

Postautor: Garreth » 18 sty 2018, 19:18

W jaki sposób przestawiłeś stepstick w spread cycle? Bo na spread cycle to poza piszczeniem przy niektórych silnikach trudno miec problemy z gubieniem kroków...

Jaki znamionowy prąd mają silniki i jaki ustawiłeś Vref na stepstickach?

77PAGO77
Posty: 4
Rejestracja: 15 sty 2018, 8:10
Kontaktowanie:

Re: Lerdge + tmc2100 Gubi kroki słabo trzyma

Postautor: 77PAGO77 » 18 sty 2018, 19:46

Podpowiedziano mi tak :
zworkę od pinu CFG1 do GND i usunąć Zworki pod stepami ze zworkami nie poszły

dałem im równo 1v

Dane techniczne
Długość silnika: 43mm
Średnica osi: 5mm
Kąt ruchu: 0,9 stopnia
Kroków na obrót: 200
Długość przewodu: 70cm
Moment trzymający: 0,39 N/m
Certyfikat: CE, ROHS
Max. temperatura: 80 stopni
Zakres temperatury otoczenia -20? ~ + 50?
Rezystancja izolacji 100M - Min. 500V DC
Wytrzymałość dielektryczna 500V AC przez 1 minutę
Okablowanie: 4:
Czerwony B +
Niebieski B -
Czarny A +
Zielony A -
Wymiary (4,3 x 4,3 x 4) cm (dł x szer x wys)
Waga: 290g

Garreth
Posty: 978
Rejestracja: 20 kwie 2016, 6:59
Lokalizacja: Katowice
Kontaktowanie:

Re: Lerdge + tmc2100 Gubi kroki słabo trzyma

Postautor: Garreth » 18 sty 2018, 20:04

Teoretycznie powinno być w porządku, ale dla pewności bym sprawdził miernikiem (na wyłączonym zasilaniu płytki!) czy na pewno pomiędzy cfg1 a GND jest połaczenie i czy na pewno na CFG2 i CFG3 nie ma połączenia ani do GND ani do 5/3.3V. Nie znam Lerdge, nie widzę schematu, więc nie wiem czy przypadkiem brak zworki nie oznacza jakiegoś podciągnięcia do GND/VCC.

Arkomania.pl
Posty: 315
Rejestracja: 20 sty 2017, 21:43
Lokalizacja: RADOM
Kontaktowanie:

Re: Lerdge + tmc2100 Gubi kroki słabo trzyma

Postautor: Arkomania.pl » 18 sty 2018, 20:51

Witam

Ja od siebie zacząłbym od sprawdzenia stabilności napięcia +5V zasilania stepstika.
Często zdarza się, że podłączenie wyświetlacza LCD powoduje spadek napięcia +5V.
Stabilizator jest za bardzo obciążony i napięcie odniesienia na stepstikach siada.

Tak np.działo się u mnie jak podłączyłem do RAMPS wyświetlacz NEXTIOM HMI LCD 4,3".
Musiałem do wyświetlacza doprowadzić osobne zasilanie +5V.
Spadek napięcia powodował jednocześnie błędne wskazania temperatury, bo pomiar
jest robiony z dzielnika tego napięcia. To samo dzieje się na Vref stepstikach.
Stabilizator 5V w RAMPS ma zbyt małą wydajność prądową, szczególnie tam
gdzie wyświetlacz pobiera dużo prądu na potrzeby podświetlania.
Pozdrawiam Arek G. arkomania

Awatar użytkownika
Kopytko
Posty: 964
Rejestracja: 19 kwie 2016, 17:04
Lokalizacja: Oleśnica
Kontaktowanie:

Re: Lerdge + tmc2100 Gubi kroki słabo trzyma

Postautor: Kopytko » 18 sty 2018, 21:32

A czy przypadkiem LERDGE nie ma logiki na 3,3V ? I Czy te tmc są na 3,3V i 5V czy tylko na 5V, są 2 wersje.
:arrow: Pozdrawiam Patryk.

77PAGO77
Posty: 4
Rejestracja: 15 sty 2018, 8:10
Kontaktowanie:

Re: Lerdge + tmc2100 Gubi kroki słabo trzyma

Postautor: 77PAGO77 » 20 sty 2018, 6:48

Nie wiem jak to sprawdzić kupowałem w BlackFrog

Garreth
Posty: 978
Rejestracja: 20 kwie 2016, 6:59
Lokalizacja: Katowice
Kontaktowanie:

Re: Lerdge + tmc2100 Gubi kroki słabo trzyma

Postautor: Garreth » 20 sty 2018, 9:34

Nie wiem czy sa dwie wersje, doku mowi ze sam chip tmc dziala na 5V. Moze wersje rzekomo na 3.3 korzystaja z wbudowanego w chip stabilizatora 5v?

A sprawdzic miernikiem mozesz napiecie na Vio. Tylko ostroznie, zebys sondami zwarcia nie zrobil!

Wysłane z mojego ONEPLUS A3003 przy użyciu Tapatalka

Awatar użytkownika
g4ever
Posty: 429
Rejestracja: 19 kwie 2016, 21:47
Kontaktowanie:

Re: Lerdge + tmc2100 Gubi kroki słabo trzyma

Postautor: g4ever » 20 sty 2018, 10:11

Garreth pisze:Nie wiem czy sa dwie wersje, doku mowi ze sam chip tmc dziala na 5V. Moze wersje rzekomo na 3.3 korzystaja z wbudowanego w chip stabilizatora 5v?

A sprawdzic miernikiem mozesz napiecie na Vio. Tylko ostroznie, zebys sondami zwarcia nie zrobil!

Wysłane z mojego ONEPLUS A3003 przy użyciu Tapatalka



Dwie wersje sa od watterota, te od mks są wzorowane na pierwszych od watterot gdzie nie bylo rozróżnienia na 3.3 V i 5 V


Wróć do „Drukarki FDM/FFF”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 1 gość