Sunbeam B co kilka włączeń gubi zawartość wsadu.

Szeroko pojęta elektronika z różnych dziedzin życia
Awatar użytkownika
mikun
Posty: 85
Rejestracja: 21 wrz 2017, 9:01
Kontaktowanie:

Sunbeam B co kilka włączeń gubi zawartość wsadu.

Postautor: mikun » 21 gru 2017, 22:47

Od dłuższego czasu mam problem z moją pierwszą drukarką czyli mendel90 a dokładnie to z elektroniką. Co kilka uruchomień muszę podłączać laptopa i wgrywać do atmegi marlina. Gdy pada soft na wyświetlaczu pojawiają się prostokąty i wiem że już nie podrukuję. Czy ktoś wie co jest powodem takich atrakcji? Zrobiłem nawet ręczne opóźnienie załączania zasilania 5V na wtyczce (w miejścu LM7805) w nadziei że to pomoże. Nic to nie pomaga. Nie pomaga też odseparowanie grzania stołu przekaźnikiem.


Obrazek

Obrazek




Chętnie kupię UNIQUE ONE

Awatar użytkownika
Krzysztof
Administrator
Posty: 2860
Rejestracja: 19 kwie 2016, 14:03
Lokalizacja: Darłowo
Kontaktowanie:

Re: Sunbeam B co kilka włączeń gubi zawartość wsadu.

Postautor: Krzysztof » 22 gru 2017, 17:07

Jakieś zwarcia na linii 5V?

Awatar użytkownika
mikun
Posty: 85
Rejestracja: 21 wrz 2017, 9:01
Kontaktowanie:

Re: Sunbeam B co kilka włączeń gubi zawartość wsadu.

Postautor: mikun » 23 gru 2017, 0:47

Mierzyłem całą linię 5V i nigdzie nie zauważyłem zwarć ani skoków napięcia. Może jakieś elektrolity na szynie 5V zwierają... dziwne że nie gubi wsadu przy każdym włączeniu tylko przy średnio co 3-5 włączeń.

Awatar użytkownika
Krzysztof
Administrator
Posty: 2860
Rejestracja: 19 kwie 2016, 14:03
Lokalizacja: Darłowo
Kontaktowanie:

Re: Sunbeam B co kilka włączeń gubi zawartość wsadu.

Postautor: Krzysztof » 23 gru 2017, 8:09

Mi tak nieraz się zdarzało i w przykładowo miałem puszony przewód zasilający blisko procka. Niby nic nie powinno się dziać a jednak. U Ciebie widzę wszystko na boki, więc to odpada. Wiem że coś w ustawieniach samego procka trzeba zmienić i problem odchodzi. Niestety nie dowiedziałem się dokładnie, ale przy Gate 2.0 właśnie taki myk był zastosowany. Jakieś 2 wartości z poziomu programatora.

Awatar użytkownika
Miś
Posty: 750
Rejestracja: 22 kwie 2016, 14:23
Kontaktowanie:

Re: Sunbeam B co kilka włączeń gubi zawartość wsadu.

Postautor: Miś » 23 gru 2017, 10:49

Jaki tam jest procek ? Możesz odczytać z niego aktualne ustawienia fusebitów ?
-- MIŚ --

Awatar użytkownika
Krzysztof
Administrator
Posty: 2860
Rejestracja: 19 kwie 2016, 14:03
Lokalizacja: Darłowo
Kontaktowanie:

Re: Sunbeam B co kilka włączeń gubi zawartość wsadu.

Postautor: Krzysztof » 23 gru 2017, 19:02

AT90USB1287
Fusy zazwyczaj ustawione są takie: lfuse:w:0x5E:m -U hfuse:w:0x99:m -U efuse:w:0xF3:m

Awatar użytkownika
Miś
Posty: 750
Rejestracja: 22 kwie 2016, 14:23
Kontaktowanie:

Re: Sunbeam B co kilka włączeń gubi zawartość wsadu.

Postautor: Miś » 23 gru 2017, 22:43

No i wszystko jasne...
lfuse powinno być 0xFF
hfuse: 0x99 (czyli tak jak jest)
efuse: 0xF0 (jeśli procek zasilany jest z 5V) lub 0xF3 (przy zasilaniu z 3.3V, ale to chyba nie ma tu miejsca).
-- MIŚ --

Awatar użytkownika
mikun
Posty: 85
Rejestracja: 21 wrz 2017, 9:01
Kontaktowanie:

Re: Sunbeam B co kilka włączeń gubi zawartość wsadu.

Postautor: mikun » 24 gru 2017, 1:11

Miś dlaczego fusy mają znaczenie na wywalanie się wsadu? Idzie to jakoś zmienić z pozycji arduino? Mam gotowy cpp czy hex już nie pamiętam wrzucam to flipem. Chyba że fusy ustawie we flipie :)

Obrazek

Awatar użytkownika
Miś
Posty: 750
Rejestracja: 22 kwie 2016, 14:23
Kontaktowanie:

Re: Sunbeam B co kilka włączeń gubi zawartość wsadu.

Postautor: Miś » 24 gru 2017, 10:58

Bo są źle dobrane. Za niski próg BOD oraz zły "Startup time" który nie powinien być używany przy pracy z kwarcu.
-- MIŚ --

Awatar użytkownika
Krzysztof
Administrator
Posty: 2860
Rejestracja: 19 kwie 2016, 14:03
Lokalizacja: Darłowo
Kontaktowanie:

Re: Sunbeam B co kilka włączeń gubi zawartość wsadu.

Postautor: Krzysztof » 24 gru 2017, 12:39

mikun, to zmienisz z poziomu programatora, przykładowo usbasp i programu mkavrcalculator
https://sklep.atnel.pl/pl/p/Programator ... culator/39


Wróć do „Elektronika”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 4 gości