Na nowej płycie ramps nie chce normalnie grzać stołu.

FoxMurder
Posty: 8
Rejestracja: 01 lip 2018, 19:13
Kontaktowanie:

Na nowej płycie ramps nie chce normalnie grzać stołu.

Postautor: FoxMurder » 02 lip 2018, 20:39

Mam problem z drukarką, poprzednia płyta padła bo byłbłąd że nie chciała ruszać osi Y, tylko ruszał w celu Home, do druku już nie.
Więc wziąłem podłączyłem ramps 1.4 zasadniczo wszystko chyba działa ale jak grzeje to stół dochodzi do ok 64-70 stopni potem wypluwa błąd
Error:Heating failed, system stopped! Heater_ID: bed
Czytałem że to pid. Majstruję w kodzie ale gu...zik to daje. Ciągle to samo jakby niezależnie od niczego. Do grzania mam 12V, i mosfet ten sam co
działał na poprzedniej drukarce i tak lepiej grzeje niż oryginalny mosfet z rampsa, przelutowałem.
Macie pojęcie jak wyłączyć na jakiś czas ten PID czy inne sprawdzanie THERMAL_PROTECTION_BED?
Na bank termistor działa i nie wypadł.

mcexperts
Posty: 588
Rejestracja: 19 kwie 2016, 18:40
Kontaktowanie:

Re: Na nowej płycie ramps nie chce normalnie grzać stołu.

Postautor: mcexperts » 02 lip 2018, 20:55

Nie jest to pid a ustawiony za krótki czas oczekiwania na zagrzanie.

Wersja partyzancka, zanim nie zmienisz programowo, ustaw 100 i co dwie -trzy minuty kliknij w host zmianę temperatury o 1 st up down I dogrzekesz do właściwej temperatury, a później puszczasz druk.

Ale kable na grubsze trzeba zmienić i lepszy zasilacz.

Awatar użytkownika
s3b
Posty: 98
Rejestracja: 19 kwie 2016, 17:25
Kontaktowanie:

Re: Na nowej płycie ramps nie chce normalnie grzać stołu.

Postautor: s3b » 02 lip 2018, 20:59

To normalne przy grzałkach typu MK2B. Przy wyższych temperaturach stół grzeje się zbyt wolno i aktywuje się zabezpieczeni termiczne. Należy odnaleźć w pliku configuration_adv.h linijki:
#if ENABLED(THERMAL_PROTECTION_BED)
#define THERMAL_PROTECTION_BED_PERIOD 20 // Seconds
#define THERMAL_PROTECTION_BED_HYSTERESIS 2 // Degrees Celsius

Na początek zmniejszyłbym #define THERMAL_PROTECTION_BED_HYSTERESIS do 1 stopnia i sprawdził czy błąd będzie nadal występował. Jeśli tak to wtedy #define THERMAL_PROTECTION_BED_PERIOD na 40 sekund.
:: Moje wydruki obecnie @P3Steel 2.01 / Ultimaker 2 AE :: Work in progress: Mostly Printed CNC ::

FoxMurder
Posty: 8
Rejestracja: 01 lip 2018, 19:13
Kontaktowanie:

Re: Na nowej płycie ramps nie chce normalnie grzać stołu.

Postautor: FoxMurder » 02 lip 2018, 21:24

Dzięki za odpowiedzi. Mam aluminiowy stół ze szkłem 3mm i słaby zasilacz i wolno grzał. Ale grzał. Wymagało to dobrego mosfeta bo ten fabryczny z rampsa to padaka spocił się że się bałem że wyparuje. Zmieniłem na stary lepszy IRL3803 ciepły ale o wiele mniej.
Rano wypróbuję pomysł.

FoxMurder
Posty: 8
Rejestracja: 01 lip 2018, 19:13
Kontaktowanie:

Re: Na nowej płycie ramps nie chce normalnie grzać stołu.

Postautor: FoxMurder » 03 lip 2018, 7:16

No więc te żółte polimery blokowały prąd, krótko po zagrzaniu stołu do ok 60 stopni. wywaliłem je zastępując drutem 1,5mm. Inaczej się nie dało. Jeste jeszcze wewn programowe zabezpieczenie.

Awatar użytkownika
marcino
Posty: 186
Rejestracja: 20 kwie 2016, 9:10
Lokalizacja: Bydgoszcz
Kontaktowanie:

Re: Na nowej płycie ramps nie chce normalnie grzać stołu.

Postautor: marcino » 03 lip 2018, 12:12

Te bezpieczniki tak mają, wystarczy jeden zmostkować (od stołu ) drugiej stronie PCB i założyć radiator na mosfed i w ramps zadbać o złącze zasilające temat powinno być :OK:
pozdrawiam Marcin ;)


Wróć do „Drukarki 3D”

Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 0 gości